Frequently Asked Questions

ANDROID - My device is not compatible.
Last Updated a year ago

Unfortunately, Qbi Mobile, is only available for Android versions 4.4.2 and beyond.

Attached you may find a list of Android's Qbi-PREMIUM compatible versions:
Android Code named
Is Compatible?
6.0–6.0.1
Marshmallow Yes
5.0–5.1.1 Lollipop Yes
4.4–4.4.4, 4.4W–4.4W.2 KitKat Yes
4.1–4.3.1 Jellybean No
4.0–4.0.4 Ice Cream Sandwich No
3.0–3.2.6 Honeycomb No
2.3–2.3.7 Gingerbread No
2.2–2.2.3 Froyo No
2.0–2.1 Eclair No

Checking your Android Version:

You may follow one of these instructions to check your current Android version:


Please Wait!

Please wait... it will take a second!